Alarms not clearing from SOI to Spectrum

Document ID : KB000044364
Last Modified Date : 14/02/2018
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Issue: 

 

Alarms that are cleared from Service Operations Insight Manager do not clear in Spectrum.

 

Cause: 

 

This issue is caused by alarm titles that are greater than 255 characters.

 

Resolution/Workaround:

 

1. Log on to the Spectrum Connector machine

2. Navigate to the $CONNECTOR_INST_DIR/SOI/resources/Core/Catalogpolicy directory

3. Make a backup of the spectrumim_policy.xml file

4. Open the spectrumim_policy.xml file in a text editor.

Find this line:

<Field conditional="causeText" output="Summary" format="{0}" input="causeText" /> 

Change to:

 

<Field conditional="causeText" output="Summary" format="{0}" input="{trunc([causeText,255])}" />

 

5. Save the file and exit.

6. Restart the Spectrum Connector.

 

Alarms with longer than 255 characters should now clear in Spectrum properly from SOI.