Alarms displayed at SOI with hostname as unknown

Document ID : KB000093052
Last Modified Date : 26/04/2018
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Issue:
We have integrated Spectrum and SOI . All alarms from Spectrum are displaying at the SOI side. But, for few alarms, we are getting a name as like "unknown" but in Spectrum hostname was displaying properly.

 
Environment:
SOI 4.0.2
Spectrum 10.2.1
Spectrum connector 2.0.0.253

 
Cause:
ci-invalid.log  we can see that the duplicated sheet is skipped because the limit was reached.

2018-03-12 20:12:26,570 INFO [Source=CA:00005_Spectrum-XXXXXXXX03@XXXXXXXX2.XXXXi.com, Thread=JMS XXXXXXXX03@XXXXXXXX2.XXXXi.com] InvalidCIs - DROPPING: The duplicated sheet is skipped because the limit was reached.
 
Resolution:
When CA SOI imports duplicate CIs from the same connector, CA SOI can create duplicate projection sheets for each CI in the notebook. In the Administration tab Global settings "Maximum Number of Projection Sheets per Notebook for a Connector Setting" value limits the number of projection sheets.

Note: Increasing the number may fix the problem once. But finding why multiple projection sheets are created in the first case would be necessary to find a final resolution for the issue. In this case the CI was a firewall device and it was changing the IP address every time.
Additional Information:
For detailed documentation please refer to the following

https://docops.ca.com/ca-service-operations-insight/4-0/en/administrating/general-administration/configure-global-settings