Agile Designer license error: Importing CmActLicense failed. An internal error occurred. Error 260

Document ID : KB000005479
Last Modified Date : 14/02/2018
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Issue:

When trying to activate a new offline license in CodeMeter Control Center, I am receiving the following error message: 
Importing CmActLicense failed. An internal error occurred. Error 260 

Environment:
CA Agile Requirements Designer (ARD)- Agile Designer
Cause:

If you are trying to apply a license without the license container present or if you are applying a license to wrong license container, you will receive this error message. 

 

Similar error message for online licenses: https://support.ca.com/us/knowledge-base-articles.TEC1895511.html 

Resolution:

First check to see if you have the AgileDesigner license container in CodeMeter Control Center (CC). 

- Directions on how to verify license container is correct and import one if missing: https://support.ca.com/us/knowledge-base-articles.TEC1760837.html 

- Once you have the license container present, try importing the new license again. 

 

license container in ccc.png

 

If you have a license container, but it is something like 'AgileDesignerUnb', 'AgileDesigner-Trial', or 'AgileDesigner-Offline', then this is incorrect. You will need to delete this license container, import the correct one (AgileDesigner), and then apply an offline license. 

- Directions on how to delete the incorrect license container: https://support.ca.com/us/knowledge-base-articles.TEC1123134.html 

- Directions on how to import the correct license container: https://support.ca.com/us/knowledge-base-articles.TEC1760837.html 

- Directions on how to create license request file, receive new license, and apply it: https://support.ca.com/us/knowledge-base-articles.TEC1147813.html 

 

wrong containers.png

 

If you have the license container imported, but the number under 'AgileDesigner' is something like 32767-2825990913 instead of 128-9928406, then this means you do not have a license activated. 

- Directions on how to create license request file, receive new license, and apply it: https://support.ca.com/us/knowledge-base-articles.TEC1147813.html 

 

activated license.png

Additional Information:

If you experience further licensing issues, please open a support case by going to https://support.ca.com/irj/portal/newhome or http://www.ca.com/us/services-support/ca-support/contact-support.html.