Agile Designer is taking a long time to open

Document ID : KB000004903
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

After upgrading to the latest version of ARD, we are experiencing a long startup period.  If one is patient, it takes 20+ minutes for ARD to come up.  Why?

Environment:
Agile Requirements Designer (ARD) on Release 2.2.800.68 or 2.3.000.4The environment is distributed running on Windows.
Cause:

The root cause is that the “Use a proxy server with connections” was selected (basically set to True).  In this specific instance, this server does NOT have an internet connection.  With this option checked, this caused the software to enter a loop checking for proxy servers on a port, wait, timeout, move on to the next port, and repeat the process.  It eventually ran out of ports and exited allowing Agile Designed to come up after 20 minutes. 

Resolution:

To correct this issue we need to go into the registry and set the specific key related to the “Use a proxy server with connections” to false.  Another way is to wait for Agile Designer to come up and change it via the UI for “Use a proxy server with connections” from true to false. Directions for both are below. 

 

1.  Go to the Registry Editor Software -> CA Technologies -> Agile Designer

2.  Double click on the showWelcomeTab and change from true to false.

3.  Save.

4.  Start ARD –> comes up immediately.

5.  Go to File -> Settings

6.  At the bottom of Settings –> "Use a proxy server with connections" is now unchecked.