Aggregation function change on a non-admin account gets distributed to all accounts except the account that changed it

Document ID : KB000123179
Last Modified Date : 19/12/2018
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Issue:
Steps to Reproduce:

1. Create either an object based portlet or a query based portlet
2. Display a number column in its layout and create an aggregation against it
 a. Assume that we have applied the "count" function against this aggregation
3. Login through a non-admin account (Give enough access rights to this account for it to see the portlet created above)
4. Access the portlet created above
5. Change the aggregation that was defined in step 2
 b. Assume that we change it to apply "maximum" function
6. Now, clear cache on the server, or restart it. This is required because the DB table responsible for holding aggregation related information is being updated incorrectly, and that incorrect update will show in the UI only when we flush cache.

Expected Result: "Maximum" function gets applied on the non-admin account's portlet. "Count" function remains applied on all other accounts.

Actual Result: "Maximum" function gets applied on admin account's portlet. "Count" function remains on account that did this change.
Cause:
This is caused by a defect with ID DE42320.
Resolution:
It is resolved in the CA PPM version expected to be released in first half of 2019.