Agents not coming online

Document ID : KB000108079
Last Modified Date : 27/07/2018
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Issue:
New install agents on Linux server not going online.
Environment:
CA Workload Automation Agents
Cause:
It's possible that the manager port is not open on the firewall for Agent and scheduling manager to communicate. Check the agent's receiver and transmitter logs for communication messages between the agent and scheduling manager, if the agent can receive the message from the manager and send massages back to the agent.

If the agent cannot communicate with the manager, you can see exception like this in the agent's transmitter log;

07/25/2018 10:45:19.230 EDT-0400 5 TCP/IP Controller Plugin.Transmitter pool thread <Slow:1>.CybTargetHandlerChannelLogHelper.logConnectionAttempt[:75] - Attempting to open conversation to ESP_TESTSCHD_7500@TESTSCHD:7507 using plain socket

07/25/2018 10:45:29.286 EDT-0400 1 TCP/IP Controller Plugin.Transmitter pool thread <Slow:1>.CybTargetHandlerChannel.constructConversation[:1190] - cybermation.library.communications.CybConversationException: connect timed out


You can use the telnet command on the agent computer to verify the connection like below;
telnet <host> <port>
Example
telnet TESTSCHD 7507
Resolution:
Open the manager port 7507 on the firewall for Agent and scheduling manager to communicate.