Agents logs filled by java.net.SocketTimeoutException

Document ID : KB000097178
Last Modified Date : 18/05/2018
Show Technical Document Details
Issue:
Java Agent logs being filled by the below error message:

[ERROR] [IntroscopeAgent.HttpURLConnectionDataResolver] getHttpStatusCode() Unable to get response code: java.net.SocketTimeoutException

What it means and how to workaround?
Environment:
Weblogic application.
Java Agent 10.x Afterwards.
Cause:
HttpURLConnectionDataResolver was used in the HTTP backend tracing and it was trying to get the HTTP status code for the HTTP call being traced when encountering this javax.net.ssl.SSLHandshakeException, ultimately the error is caused by a timeout in Weblogic itself
Resolution:
1) Behoves upon customer to resolve the timeout in Weblogic itself.

2) You can remove this message by doing:

a) Go inside your Agent_Home > Core > Config folder
b) Search for "httpbackendmetrics.pbd"
c) Inside it, searh for "TraceOneMethodIfFlagged: HttpURLConnectionBackend getInputStream()Ljava/io/InputStream; HttpURLConnectionClientBackendTracer "WebService at {protocol}_//{host}_{port}" and leave as below:

#TraceOneMethodIfFlagged: HttpURLConnectionBackend getInputStream()Ljava/io/InputStream; HttpURLConnectionClientBackendTracer "WebService at {protocol}_//{host}_{port}"

d) Save the file
e) Restart the application.
Additional Information:
As expected, after commenting out the directive some few metrics can be missed.