Agent plugin upgrade job hangs when upgrading agents using software delivery.

Document ID : KB000044041
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem:

Agent plugin upgrade job hangs when upgrading agents using software delivery. The job starts and CAF services get stopped on the agent but the upgrade never completes.

 

Environment:  

CA Client Automation - All Versions

 

Cause: 

This will happen if the software delivery agent is set to use a NOS connection for deployments. Since a NOS connection requires a connection to the scalability server to run the upgrade, that connection is broken durring the upgrade process and the upgrade job cannot continue.

 

Resolution:

Set the agent to use a NOS-less connection and then send the upgrade job.

 

Additional Information:

Please see technical document TEC484792 for details on switching NOS types.

http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec484792.aspx?intcmp=searchresultclick&resultnum=1