Agent install GUI fails to start

Document ID : KB000014430
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

You are trying to install WebAgent on your Windows Machine.

But all you can see is the progress bar showing the extraction of files.

Then nothing is displayed but the installer continues and successfully completes the installation.

To make matters worse, IIS cannot be configured via console mode. So Agent configuration wizard must show the GUI or the IIS configuration cannot be performed.

Question:

What could be the reason why the installer(or the Configuration Wizard) is not displaying any GUI window?

Environment:
Windows 2008 R2 and above.Windows 12.5x and above.
Answer:

The reason why there is no GUI could be due to OS setting.

If you goto "%userprofile%" folder, see if you have ".accessibility.properties" file.

 

This file can be created by following steps.

 

1. Go to: Start->Control Panel->Ease of Access->Ease of Access Center

2. Select “Use the computer without display”

3. In the section “Other Programs Installed” select/check the checkbox “Enable Java Access Bridge”

 

Or, you might have run the following command.

"jabswitch.exe /enable"

 

jabswitch.exe is located in your "JRE/bin" folder. 

 

If you had this setting enabled, it forces javaw.exe run by the installer to not display the GUI window.

Reversing these steps would not fix your problem.

You must delete this file "%userprofile%\.accessibility.properties".

Only then the installer will display GUI.

 

Additional Information:

https://communities.ca.com/people/SungHoon_Kim/blog/2017/05/15/product-installer-is-not-displaying-gui