Agent Client Assignment Object does not work, Clients are not authorized as defined

Document ID : KB000100570
Last Modified Date : 16/01/2019
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Issue:
An Agent Client Assignment (HSTA) Object, which worked in older versions of the Automation Engine, doesn’t work anymore after an update to version 12.1.

After a new Agent is installed and connects to the Automation Engine the first time, it should be assigned to specific Clients, based on an Agent Client Assignment, during the Agent onboarding.
Even the filter criteria match and the HSTA is active, the Agent is not automatically authorized for the Clients as specified in the HSTA.

Example and steps to reproduce:

  • Create an Agent Client Assignment (HSTA) Object, which filters for example on all Agent Names starting with “VWGSUP*”. Make sure to choose a License Category as well, even there is no License Category specified in the Agent’s ini File. Set some Client Authorizations: 
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  • Verify that the HSTA Object is set to active in the Administration Perspective -> Agents & Groups -> Agent Authorization Policies: 
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  • Stop Agent VWGSUP12_#3
  • Modify its ini file and change the name to VWGSUP12_#3_NEW
  • Start the Agent
  • The Client Assignment is not automatically done as expected: 
User-added image

 
Cause:
There is no License Category available by default, during the Agent onboarding. Except it is specified within the ini file of the Agent, in the variables section.
This was ignored in older versions by mistake and therefore Agents were authorized, even there was a mismatch at the License Category.

Due to the so called new Agent onboarding, the behavior was reworked an optimized for big environments (for more than 100k Agents). During that this leak was closed. Agents are authorized only if the specified License Category match.
 
Resolution:
Remove the License Category in the Agent Client Assignment Object, in case it’s not specified in the ini file of the Agent.

In addition, a hint in the Documentation will be added.
 
Additional Information:
In case there are a lot of Agent Client Assignment Objects in place, the following SQL statement lists all of them having a License Category set:
select OH_NAME from OH where OH_DELETEFLAG = 0 and OH_IDNR in (select OHAF_OH_IDNR from OHAF where OHAF_LICCATEGORY is not null);