After upgrading UIM 8.47 or lower to Java_jre 1.73 package that includes Java 1.7.85 all the java probes on the primary stop working. Why did this break all the Java probes?

Document ID : KB000011856
Last Modified Date : 14/02/2018
Show Technical Document Details
Question:

We downloaded the Java_ajre version 1.73 in order to deploy to the primary
to update the java to 1.7.85 to deal with a security scan problem.
When we did this and restarted the primary UIM robot all of the java probes failed to start.
Why did this happen and how do we correct it in oder to apply the latest Java_jre?

 

Environment:
UIM 8.47 or earlierJava_jre 1.73 or newer
Answer:
 
 

the new java_jre is being rolled out for 8.5 has a different format than than all older version of the product.

This is what causes the problem and causes all of the java probes to stop working.

I was able to correct this by doing the following
1) deploy the 1.73 JRE to the primary uim server.
2) deactivate the nimsoft robot watcher service
3) rename the nimsoft\jre\jre7 to nimsoft\jre\jre7_old
4) create new nimsoft\jre\jre7
5) from inside the nimsoft\jre\jre-7u85-windows-x64.7z copy jre7\jre\ to nimsoft\jre\jre7\jre
6) you should not have the same original structure for 8.47 and below java JRe folders

Final structure:
Nimsoft\jre\jre7\bin
Nimsoft\jre\jre7\lib

( there are other sub folder beneath the two above but these should be the only folders in the nimsoft\jre\jre7 folder


7) Restart nimsoft.

This should allow all of the java probes to come up and start working including admin console.