After upgrading to UIM v8.47, ldap users are not able to login

Document ID : KB000047555
Last Modified Date : 14/02/2018
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Issue: 

After an upgrade to UIM 8.47, members of an LDAP group are unable to login

Errors like this repeatedly appear in the hub.log:

Logging on to domain "DOMAIN" as user "USER" 

Validating basic Nimbus permission.... (Operator access) 

Permission denied for request (hubsec_list). Will attempt relogin..... 

Relogin (user:user@email.com) succeeded 

 

Permission denied for request (hubsec_list). Will attempt relogin..... 

 

Environment:  

This issue was found using UIM 8.47 but this information is generally applicable to most versions of UIM.

 

Cause:

 

This issue is caused by the ACL losing it's pointer to the LDAP group.

To correct it, the LDAP group will need to be reset with the ACL.

 

Resolution:

1. In Infrastructure Manager, click on the 'Security' drop down menu and select 'Manage Access Control List...'

2. Select the ACL that this LDAP group is associated and click 'Set LDAP Group...'

3. (Re)select the appropriate LDAP group and click 'OK' to resync the group with the ACL