After Upgrading the Endpoint, Commands Return a CAPKI Library Error

Document ID : KB000098883
Last Modified Date : 31/05/2018
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Issue:
After a PIM or UNAB endpoint has been upgraded, it is observed that CAPKI library errors are occurring when running commands.

Example:
# seretrust 
Retrusting PROGRAMs & SECFILEs, Base path = / 
Total of 0 entries found in class SECFILE 
Could not get function dispatch table for CAPKI library 
Could not get function dispatch table for CAPKI library 
Could not get function dispatch table for CAPKI library 
CA ControlMinder selang v12.81.0.3134 - CA ControlMinder command line interpreter 
Copyright (c) 2013 CA. All rights reserved. 
Could not get function dispatch table for CAPKI library 
Could not get function dispatch table for CAPKI library 
Could not get function dispatch table for CAPKI library 
Could not get function dispatch table for CAPKI library 
Could not get function dispatch table for CAPKI library 
Could not get function dispatch table for CAPKI library 
Could not get function dispatch table for CAPKI library 
Total of 0 entries found in class PROGRAM 
Cause:
The issue is caused because the CAPKI upgrade was not successful, so the CAPKI libraries are either missing or were not updated. Running `ls -laR /opt/CA/SharedComponents/CAPKI` to check if the CAPKI files exist and check the modification time of the files in the CAPKI directory. If another CA product is running while upgrading PIM, CAPKI may be in use and the library files will not be updated.
Resolution:
To ensure that CAPKI gets installed properly, one must uninstall and re-install the endpoint. If it is the only CA product on the server, check that the CAPKI directory (/opt/CA/SharedComponents/CAPKI by default) is removed after installation. If there are other CA products on the server, stop them prior to uninstalling and re-installing the endpoint.