After upgrading from CA Service Desk Manager (CA SDM) 12.9 to CA SDM 14.1, unable to run the CA SDM configure utility (pdm_configure). It gives an error "A java exception has occurred"

Document ID : KB000030740
Last Modified Date : 01/02/2019
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Issue:

After upgrading from CA Service Desk Manager (CA SDM) 12.9 to 14.1, unable to run the CA SDM configure utility (pdm_configure). It gives an error "A java exception has occurred"

pdm_configure.JPG

Environment:
Service Desk Manager 12.9, being migrated to later releases of Service Desk.
Cause:
This error is a result of some *.JAR files missing in the NX_ROOT\java\lib" folder.  The most likely cause may be an interruption on the install process or insufficient permissions to copy/modify the files (running the installer as a non-admin user)
Resolution:

Copy all the missing *.JAR files from a CA SDM 14.1 installation's NX_ROOT\java\lib directory where the CA SDM configure utility works properly.

NOTE: NX_ROOT stands for the directory where CA SDM is installed to.

Additional Information:
The attached text file, NX-Root-Jar-File-Dir-List.txt,  contains a list of jar files present in a healthy Service Desk 14.1 install, under NX_ROOT\java\lib.  Date/timestamps may vary depending on patch level.
File Attachments:
NX-Root-Jar-File-Dir-List.txt