After upgrading AS400 node to 6.7.21 the uproc variables are no longer taken in account in the uprocs within the session

Document ID : KB000085367
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
 Example of job log:
=================================================================================================================================
C00-SUPPORT-SITE DEBUT
C00-SUPPORT-SITE WSPGM-CODNOEUD FRSTI713
_!================================================
_!**
$|** PROCEDURE .. : UPR_AVIVA_SERVICIO_002
$|** VERSION .....: 000
$|** EXECUTION .. : 0010178
_!**
$|** SESSION .... : UNIV_AVIVA_SESSION
$|** VERSION .... : 000
$|** EXECUTION .. : 0000002
_!**
_!** PROCESS DATE : 03/21/2017
_!**
_!------------------------------------------------
$|** PARAMETERS. : None
_!------------------------------------------------
_!** VARIABLES
UXJOB :AVIVA11
UXJOBD :UNIV66
....
 5770SS1 V7R1M0 100423 Display Job Log FRSTI713 03/21/17 14:31:15 Page 1
 Job name . . . . . . . . . . : X0010178 User . . . . . . : UNIVADM Number . . . . . . . . . . . : 856740
 Job description . . . . . . : QDFTJOBD Library . . . . . : QGPL
MSGID TYPE SEV DATE TIME FROM PGM LIBRARY INST TO PGM 

In the spool output you can see that default jobname and default jobd are used.

UXJOB and UXJOBD specify Jobname and Job Description to be used, but in the spool output the default job name X001078 and the default Job Description QDFTJOBD are used! 

Patch level detected:Dollar Universe 6.7.21
Product Version: Dollar.Universe 6.7.21

Description :The uprocs (not the headers) executed within a session are unable to use their definition of SBMJOB parameter like e. g. UXJOB, UXJOBD and UXJOBQ. They systematically use the default values of these variables that come from the user profile or the default job description.
This can be checked by reading the job log of such an uproc, when comparing the values of variables in the Job Log and the values applied in the spool output.
Environment:
OS: IBM AS/400
Cause:
Cause type:
Defect
Root Cause: This is a bug specific to the version Dollar Universe 6.7.21 for AS400.
Resolution:
There is no workaround to this problem, the solution is to upgrade to Dollar Universe 6.7.23 or higher.

Fix Status: Released

Fix Version(s):
Component: Application.Server
Version: Dollar.Universe 6.7.23
Additional Information:
Workaround :
N/A