After upgrading a test DB2 subsystem to DB2 11 CM, why am I not able to get into Sysview Performance Monitor for DB2 for z/OS (IDB2)?

Document ID : KB000040159
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem

After upgrading a test DB2 subsystem to DB2 11 CM, why am I not able to get into Sysview Performance Monitor for DB2 for z/OS (IDB2) from the CA DB2 Tools' Main

Menu?  Selecting 'IS' for Sysview Performance Monitor for DB2 for z/OS (IDB2) from the CA DB2 Tools' main menu I receive the message: 

CA SYSVIEW FOR DB2 USER SESSION FAILED WITH RC=12 ENSURE THE POST INSTALL STEPS HAVE BEEN COMPLETED BEFORE INVOKING THE USER INTERFACE.

Cause: 

Maintenance had been applied to the CA DB2 Tools, and the propagation of the SMP/E Target libraries to the CA DB2 Tools' Runtime libraries caused the previously

modified Insight clist (from the Post Install process) to be overlaid with a 'vanilla' unedited version, thus the cause of the error message. 

Resolution:

A backup copy of the edited Insight clist was copied into the CA DB2 Tools' runtime clist (CDBACLS0) library.  This corrected the error condition.