After upgrade to APM 9.7 and 10.x dashboards and metric groupings for CEM RTTM/BtStats metrics have no data and "TESS Agent" sub-node is missing from Investigator Metric Browser CEM branch.

Document ID : KB000044460
Last Modified Date : 14/02/2018
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Problem:

After upgrade to APM 9.7 and 10.x dashboards and metric groupings for CEM RTTM/BtStats metrics have no data and the "TESS Agent" sub-node is missing from the Investigator Metric Browser CEM branch.

 

Cause:

From 9.7 there is a new feature to organize RTTM metrics by user group. As part of that the Metric Browser node for CEM data no longer has a single "TESS Agent" sub-node and instead there is a separate sub-node for each CEM Application Name. For details see:

CA APM Release Notes > CA APM Release 9.7.0 > Enhanced RTTM by User Group

 

Resolution:

It is possible to revert the change and retain the pre-9.7 "TESS Agent" node structure with a property change. This property must be set to false in the file EM_HOME/config/tess-default.properties on the Enterprise Manager running the TIM Collection Service, whose SmartStor is where RTTM metrics are stored:

cem.btstats.multiple.agent.nodes.enabled=false