After upgrade getting Requested Message Key Not Found errors

Document ID : KB000008497
Last Modified Date : 14/02/2018
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Issue:

After the upgrade we are finding error messages like this in our hco log files:

E03080003: Requested Message Key Not Found: : HAPI_I_BROKER_CONNECT
E03080003: Requested Message Key Not Found: : HSRV_I_SAME_VERSION_NOT_MODIFIED
E03080003: Requested Message Key Not Found: : HSRV_I_SAME_VERSION_NOT_MODIFIED
E03080003: Requested Message Key Not Found: : HSRV_I_SAME_VERSION_NOT_MODIFIED
E03080003: Requested Message Key Not Found: : HSRV_I_SAME_VERSION_NOT_MODIFIED
E03080003: Requested Message Key Not Found: : HSRV_I_SAME_VERSION_NOT_MODIFIED
E03080003: Requested Message Key Not Found: : HSRV_I_SAME_VERSION_NOT_MODIFIED
E03080003: Requested Message Key Not Found: : HSRV_I_SAME_VERSION_NOT_MODIFIED
E03080003: Requested Message Key Not Found: : HSRV_I_SAME_VERSION_NOT_MODIFIED
E03080003: Requested Message Key Not Found: : HAPI_I_EXECUTE_SUCCESS
E03080003: Requested Message Key Not Found: : HAPI_I_CHECKOUT_SUMMARY
Checkout has been executed successfully.

Cause:

We navigated to the $CA_SCM_HOME folder and checked file permissions using "ls -al *.msg". We found that the *.msg files were configured to only be readable by the file's owner, and not visible for anyone else (-r--------).

Resolution:

We executed chmod for each file to make it world readable (chmod a+r *.msg) and the problem was resolved.

We will need to repeat this process on every Unix/Linux computer where the SCM Client was installed.