After Refreshing PPM Data From Prod to Test the Agile Central Sync Job Fails

Document ID : KB000102882
Last Modified Date : 28/06/2018
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Issue:
The CA Agile Central sync job is failing after refreshing the data from Prod to our Test environment.  In the logs we see the following messages:

ERROR 2018-06-20 08:21:54,997 [Dispatch Rally Synchronization-06202018-1 : bg@PPMSERVER (tenant=clarity)] client.RallyContext (clarity:PMO@MYCOMPANY.com:57301203__76E95069-42B6-437F-BAB8-6B733CCDC1C3:Rally Synchronization-06202018-1) Problem while retrieving Agile Central integration details, no details found for id:DFS_PPM_TO_AC 

ERROR 2018-06-20 08:21:54,997 [Dispatch Rally Synchronization-06202018-1 : bg@PPMSERVER (tenant=clarity)] ppm.rally (clarity:PMO@MYCOMPANY.com:57301203__76E95069-42B6-437F-BAB8-6B733CCDC1C3:Rally Synchronization-06202018-1) Either Context or Connection is not set properly, Check integration Setting com.ca.ppm.rally.client.RallyContext@61f48198 

ERROR 2018-06-20 08:21:54,997 [Dispatch Rally Synchronization-06202018-1 : PPMSERVER (tenant=clarity)] ppm.rally (clarity:PMO@MYCOMPANY.com:57301203__76E95069-42B6-437F-BAB8-6B733CCDC1C3:Rally Synchronization-06202018-1) Error occurred while populateWorkspaceHierarchy. request= java.io.IOException: Rally API Error : RestAPI Connection is not set properly in Context 

ERROR 2018-06-20 08:21:55,005 [Dispatch Rally Synchronization-06202018-1 : bg@PPMSERVER (tenant=clarity)] ppm.agl (clarity:PMO@MYCOMPANY.com:57301203__76E95069-42B6-437F-BAB8-6B733CCDC1C3:Rally Synchronization-06202018-1) Error while syncing projects 
Environment:
CA PPM 15.x and above
Cause:
This issue is caused by the CA Agile Central Integration settings being wiped out by the data refresh from prod to test.  
Resolution:
Reconfigure the integration again following the steps here: 
https://docops.ca.com/ca-ppm/15-4/en/add-ins-and-integrations/integrate-ca-ppm-with-ca-agile-central#IntegrateCAPPMwithCAAgileCentral-agileaddinConfiguretherallyIntegration 

NOTE: After reconfiguring the integration, you must recycle the BG service.  For SAAS customers, please open a support case requesting for the BG service to be recycled on the environment.  Be sure to specify the environment URL as well as a time frame for when you would like the recycle to occur.