After logging into CA PAM there is a message: "Bind Failure" "The following loopback addresses could not be loaded..."

Document ID : KB000047012
Last Modified Date : 14/02/2018
Show Technical Document Details

Symptom:

When logging into CA PAM or visiting the Access page a message pops up saying: "Bind Failure" "The following loopback addresses could not be loaded: ..."

bindfail.jpg

Cause:

When the CA PAM Access page first loads it attempts to bind to all of the ports that it may need to use for the TCP/UDP Services the user has access to. This message occurs because the address/port that it is trying to bind to is already in use when it attempts to bind to it. This error will mostly impact the functionality of TCP/UDP Services, standard Access Methods (and the CA PAM GUI) will usually continue working without problems.

1) The most common cause is when there is already a CA PAM session open and a second one is started. Since the ports are already bound by the first session it is impossible to bind them again in the new session. 

2) The port may be blocked by a firewall.

3) The port may be held open by a hung process or in use by some other software on the computer.

4) Mac systems have a limitation where these TCP/UDP ports must be above 1024 to work properly.

Resolution:

1) Close all CA PAM sessions (both browser & CA PAM Client) and open a new one.

2) If the system has a firewall enabled, ensure that the port(s) in question are not blocked.

3) Is the port in use? It is possible to find out using basic networking commands:

The commands below will output all open ports along with the PID of the process that is using them. The PID can then be used to determine which process is holding the ports. If the process is not important or is hung then it can be killed which should release the port for use. If it turns out to be an important process or it is found that this message is seen often with a specific port then changing the TCP/UDP Service settings may be the best option. 

Linux: # netstat -p

Mac: # lsof -Pnl +M -i4

Windows: > netstat -ao

On Lunix & Mac the PIDs of currently running processes can be found using the ps command: # ps -elf

On Windows the PIDs of currently running processes can be found using the tasklist command: > tasklist

4) Change any ports under 1024 to a number higher than 1024.