After installing UAPM 11.3.4 with the ADT interface and the Prerequisite patch, QO99416, I cannot reinstall the UAPM/ADT interface. I am receiving the error, "Incorrect UAPM Version (11.03.0401) - version must be exactly 11.03.0400 in order to install..."

Document ID : KB000054297
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

After installing UAPM 11.3.4 with the ADT interface and the Prerequisite patch, QO99416, I cannot reinstall the UAPM/ADT interface. I am receiving the error, "Incorrect UAPM Version (11.03.0401) - version must be exactly 11.03.0400 in order to install this product."

Solution:

IMPORTANT: This article contains information about modifying the registry.
Before you modify the registry, make sure to create back up of the registry and ensure that you understand how to restore the registry if a problem may occur.
For more information about how to back up, restore, and edit the registry, please review the relevant Microsoft Knowledge Base articles on support.microsoft.com.

The UAPM 11.3.4 prerequisite patch, QO99416 changes the version of UAPM stored in the Windows registry from 11.03.0400 to 11.03.0401. If you need to reinstall ADT after applying patch QO99416, you must first change the registry key containing the current version of UAPM to match the required version, perform the installation, then change the registry key back to it's original value.

Use the Window's regedit utility to view and modify the Windows registry. For instructions on using Regedit, refer to Regedit Help within the program.

The registry key to change is:

HKEY_LOCAL_MACHINE\software\computer associates\unicenter asset portfolio management

Change the data value from 11.03.0401 to 11.03.0400

Close regedit and perform the reinstallation of ADT, then use regedit to revert the key back to its original value.