After install of Napatech Driver the TIM apmpacket process is failing to process any data from the Napatech interface.

Document ID : KB000039352
Last Modified Date : 14/02/2018
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Problem:

After successful install of Napatech Driver the TIM Setup UI/Interfaces page shows the Napatech card which is receiving traffic and it has been selected.

However the TIM Setup/Packet Statistics gives an error when trying to be displayed and in the TIM log these error messages for apmpacket are repeated on a regular basis:

**ERROR: hub: ApmPacketComm: timapmpacketcomm: 

**ERROR: hub: ApmPacketComm: config client response error from timapmpacketcomm

**ERROR: hub: hubmanager: could not configure apmpacket. Retrying ...

Even after a tim restart from UI or command line ("service tim restart") the problem still remains

 

Environment:

APM TIM 9.7, 10.0, 10.1, 10.2

 

Cause:

In APM 9.7 and later versions the TIM architecture has been performance enhanced with a separate apmpacket process. That process needs to be reconfigured with the Napatech pcap library and restarted

 

Resolution:

1. Follow the instructions on the APM 9.7, 10.x wikis to configure the apmpacket configuration file /opt/CA/APM/apmpacket/config/apmpacketsettings.db with the Napatech pcap library 

APM Installation and Upgrade - Installing APM TIM Napatech Drivers - Register pcap with TIM

i.e. Step 3 here:

3. Update the apmpacket application as follows:

/opt/CA/APM/tim/bin/configtool -f /opt/CA/APM/apmpacket/config/apmpacketsettings.db -s libpcapPath /opt/napatech3/lib/libpcap.so

2. Then restart the apmpacket process which runs separately from the tim process itself and has a separate service. Restart using:

service apmpacket restart

3. Restart the TIM itself. Confirm that the Packet Statistics page does now show data and the TIM log no longer contains the apmpacket errors.