After deployment, Tomcat probe doesn't show up in IM, neither in Admin Console.

Document ID : KB000004396
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

After deployment of the tomcat probe to a robot installed in a Solaris OS, the probe doesn't show up in IM, neither in Admin Console. This same behavior was experienced also with the jboss probe, however, other probes like the zones probe could be successfully deployed, and it showed up in the AC and IM consoles.

 

In controller.log, you can find error messages like: 

 Oct 19 16:37:43:101 [0001] Controller: MyStringExpand (rm "probes/application/jboss/jar/nimsoft.jar" "probes/application/jboss/jar/nimsoft-eb-jsr160.jar" "probes/application/jboss/jar/Twofish.jar")... 

Oct 19 16:37:43:103 [0001] Controller: Pre-install command rm "probes/application/jboss/jar/nimsoft.jar" "probes/application/jboss/jar/nimsoft-eb-jsr160.jar" "probes/application/jboss/jar/Twofish.jar" returned 512 exited with 2 

Oct 19 16:37:43:104 [0001] Controller: inst_execute - pre-install failure; installation of section SOLARIS in package tomcat aborted 

Oct 19 16:37:43:104 [0001] Controller: SREPLY: status = 7(temporarily out of resources) ->192.xxx.xxx.xx/59430 

 

and in distsrv.log: 

 

Oct 19 07:02:32:939 [6684] distsrv: unzip - zipfile not found for C:\Program Files (x86)\Nimsoft/archive/tomcat.zip 

Oct 19 07:02:33:124 [6684] distsrv: Dependency check error: Unable to find any version of package jre_solaris on /domain/hub/unknown 

 

 

jre_solaris was installed in the system.

Environment:
CA UIM 8.47 + Solaris 10
Cause:

Defined probe pre-requisites were preventing a successfully install of the probe in the robot.

Resolution:

1. If you are using jboss probe, deactivate the probe and move the below

files into different directory.

1-1. probes/application/jboss/jar/nimsoft.jar

1-2. probes/application/jboss/jar/nimsoft-eb-jsr160.jar

1-3. probes/application/jboss/jar/Twofish.jar

 

2. Log In to Primary HUB Server via Infrastructure Manager

3. Go to Archive

> Your HUB > Application. Highlight and right click tomcat probe and go

[Edit]

4. Package Editor will come. Go [SOLARIS] tab > [Miscellaneous] tab

5. Remove all the arguments in [Pre install command] section.

6. Save the change and finish the Package Editor.

7. Deploy the pacakge.

Additional Information:

As always, please contact CA Technologies support for CA UIM if you have further questions.