After deploying uim_aws_dashboards_pack, we are still not able to see the report AWS Summary - Error No dashboard found with this path

Document ID : KB000007982
Last Modified Date : 14/02/2018
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Issue:

After deploying uim_aws_dashboards_pack, we are still not able to see the report AWS Summary - Error No dashboard found with this path

This problem may happen with other dashboard packs as well.

error.jpg

Environment:
UIM 8.5.1cabi 2.0
Cause:

There are a few possible causes to this problem.

1-      The browser needs to add a 3rd party site data exception.

2-      The dashboard does not exist on the CABI server

3-      The path to the dashboard in jaspersoft is incorrect.

Resolution:

The steps below will help to diagnose and resolve the issue in your environment.

1-      Developer Tools Steps using Chrome:

·         Open the Developer Tools from the menu (Menu > Tools > developer tools), or by pressing Ctrl+Shift+C on your keyboard

·         Click on the Network tab

·         Look for a round button at the top left of the Network tab. Make sure it is red. If it is grey, click it once to start recording.

·         Check the box next to Preserve log.

·         You can use the clear button (a circle with a diagonal line through it) right before trying to reproduce the issue to remove unnecessary header information

2-      In the output, look for a red line with an error message as shown in Figure 1 below.

 Figure 1: 

Figure1.JPG

 

 

3-      Determine if you are receiving a “401 (authentication)” or a “404 (not found)” error. If you see a “401 Authentication” error, please reference this document to resolve the issue.

If you receive a “404”, continue below with step #4. 

4-      Login to your CABI server directly.  Login with User: superuser / Password: superuser or a UIM user.

5-      Navigate to Home.  “Dashboards” > “View List” as shown in Figure 2 below.

Figure 2:

Figure2.jpg

6-      Review the available list of dashboards.  Ensure the desired dashboard is visible here and is functional.

Note if the dashboard is not present, then use the admin console to re-deploy the ump_aws_dashboard to the cabi robot.  Review the cabi robot: /opt/nimsoft/probes/service/cabi/cabi.log for any errors.

If successful, it should display something like the following:

Aug 26 00:40:00:985 [ContentUploaderPool-1-thread-1, cabi] uploading file=/opt/nimsoft/probes/service/cabi/content/upload/uim_aws_dashboards.zip ....

Aug 26 00:40:09:050 [ContentUploaderPool-1-thread-1, cabi] successfully uploaded file=/opt/nimsoft/probes/service/cabi/content/upload/uim_aws_dashboards.zip

 

Return to this dashboard list page to ensure the dashboard is visible, as shown in Figure 3.

Figure 3:

Figure3.jpg

7-      Right- Click the dashboard and select “Properties” from the right click context menu as shown in Figure 4.

 Figure 4:

Figure4.jpg

 

8-      Take a note of the path.  This may be important later for debugging or Support as shown in Figure 5.

 Figure 5:

Figure5.jpg

 

9-      Return to the UMP console.  Attempt to open the same dashboard as shown in Figure 6.

Figure 6: 

Figure6.jpg

 

10-      Click on the wrench icon on the top right of the screen as shown above (“Options”).

Select “Preferences” as shown in Figure 7:

Figure 7: 

Figure7.jpg

11-      This will bring up the properties page for the dashboard.

Note the “Dashboard Path”, for example as shown in Figure 8.

Figure 8:

Figure8.jpg

12-      Open the “Dashboard Path” drop down box.  Select the appropriate dashboard from the list as shown in Figure 9.

Figure 9:

Figure9.jpg

13-      Save the properties and at this point, the dashboard should be functional.  Click “Return to Full Page” to see the dashboard as shown in Figure 10.

Figure 10:

Figure10.jpg

 

Additional Information:

What files do I need to send to support if I experience issues with CA Business Intelligence Dashboards?

There are multiple files to send to support. In some instances, multiple versions of a file might exist due to date and timestamps. Send the most current file from the following locations:

1.    Go to the file system of the robot where the cabi probe is installed.

2.    Copy the following files depending on your UIM version.

o    CA UIM version 8.5.1:

§  Go to <UIM_installation>\c and copy upgrade.properties_<date_time>.
For example, upgrade.properties_2017-01-24_09-57-02-223

§  Go to <UIM_installation>\c\ca_install and copy all the files in the directory that follow the format uim.<filename>.
For example, uim.log, uim.properties, and uim.log_2017-01-24_09-57-02-223

o    CA UIM version 8.5 and earlier:

§  Go to <UIM_installation>\cabi and copy upgrade.properties_<date_time>.
For example, upgrade.properties_2017-01-24_09-57-02-223

§  Go to <UIM_installation>\cabi\ca_install and copy all the files in the directory that follow the format uim.<filename>.
For example, uim.log, uim.properties, and uim.log_2017-01-24_09-57-02-223

3.    Go to <UIM_installation>\probes\service\cabi

4.    Copy the following files for the cabi probe:

o    _cabi.log

o    cabi.log

o    cabi_install_archive.log

o    cabi.cfg

o    content (Copy the entire directory.)

5.    Go to Admin console and view the primary hub robot.

6.    Expand the data_engine menu and click View Config File.

7.    Download data_engine.cfg.

8.    Expand the data_engine menu and click View View Probe Utility in New Window.

9.    Run the command get_connection _string.

10.  Export the output to a CSV file.