After copying an MDB database from one Service Desk environment to another, pdm_configure fails because the server name differs from that in the mdb. The database you are trying to use was previously configured to be used by the server (servername)

Document ID : KB000045759
Last Modified Date : 14/02/2018
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Problem:

After copying an MDB database from one Service Desk environment to another, when running pdm_configure a message appears on the database settings dialog:

'The database you are trying to use was previously configured to be used by the server (servername)....'.

It gives a prompt to 'Choose OK to allow this Primary Server to use the selected database.', but if you click OK nothing happens. The following message may be seen in the configure.log in NX_ROOT\log:

08/16 09:18:50.740 INFO  SQLDatabasePage.java  1056 The Value of swing_box_migrate is : null

 Environment: 

CA Service Desk Manager 12.9 and 14.1 

Cause:

The name of the Service Desk server in the dlgtsrv table does not match the name of the server on which the pdm_configure is being performed. 

Resolution:

A fix introduced in Service Desk Manager 12.9 CUM1 requires that the NX.env parameter  @NX_SWING_BOX_MIGRATE be set to yes. With this set the server name checks will be ignored. The following instructions explain how to add the variable to the NX.env file:

1. Run the following command from the command prompt on the primary or background server to add the parameter with a value of Yes:

pdm_options_mgr -c -s SWING_BOX_MIGRATE  -v Yes -a pdm_option.inst

 

2. You can then set the value of NX_SWING_BOX_MIGRATE to No after the pdm_configure is successfully completed, using the following command:

pdm_options_mgr -c -s SWING_BOX_MIGRATE  -v No -a pdm_option.inst

 

3. To retain the changes made when you run subsequent pdm_configure commands, run the following command:

pdm_options_mgr -c -s SWING_BOX_MIGRATE  -v No -a pdm_option.inst -t

Note that this will update the template file ($NX_ROOT\pdmconf\NX.env_nt.tpl)

 

Note that if you want to use this parameter in the Service Desk 12.9 GA Release (prior to CUM1), open a case with CA Support and ask for a fix for problem USRD 2872

 

Additional Information:  

 There is a further explanation of this parameter in the Service Desk Manager 14.1 documentation.