After an upgrade to CA Common Services 14.0 or 14.1, you may experience various problems with CA-Librarian

Document ID : KB000020520
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

After upgrading to CA Common Services for z/OS v14.0 or r14.1, customers may experience various problems executing different functions of CA-Librarian. Reported problems include a U2000 in module UTIMAIN and a return code of 4061 when executing the CA Librarian batch program, AFOLIBR. The problem will occur if the CA-C Runtime component has not been installed for CA Common Services v14.0 or r14.1. In previous CA Common Services for z/OS releases, the CA-C Runtime modules required for CA-Librarian were found in the CAILIB or CAILOAD library which was generally linklisted. However, beginning with v14.0, the CA-C Runtime component is delivered as one of the LEGACY components in a separate PAX file under FMID CAF3E00. The necessary modules are now found in the CCCSLINK data set which needs to be defined to the system linklist .

NOTE: Similar problems can be witnessed with other CA mainframe solutions. Check your individual CA mainframe products installation guide for the required software requirements.

Solution:

Ensure that FMID CAF3E00 has been installed and the cai.CCCSLINK is both linklisted and APF authorized.