After an upgrade of the CA Workload Automation Engine from version 12.1.2 to 12.2.0 the JWP and the JCP won't start up correctly.

Document ID : KB000104083
Last Modified Date : 14/08/2018
Show Technical Document Details
Issue:
When starting the JWP after an upgrade of the CA Automic Workload Automation Engine (AE) from 12.1.2 to 12.2.0 the JWP is not starting but giving the following error:

org.osgi.framework.BundleException: The bundle "com.automic.ara_1.0.0 [24]" could not be resolved. Reason: Missing Constraint: Import-Package: com.automic.protocol; version="1.0.0"
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1332)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1316)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:300)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:292)
    at com.automic.server.startup.Main.main(Main.java:123)
Resolution:
Workaround:
The file com.automic.ara.jar (located in the AutomationEngine/bin/plugins folder) is no longer shipped with v12.2 and was left over when the binaries were upgraded.
After removing this file (cut and save somewhere outside the Automation Engine) the JWP and JCP will 

Solution:
Please upgrade to a fix version or a higher on if available.

Componet(s):
Automation Engine

Fix Version(s):
Automation.Engine 12.2.1 - planned Release date 2018-10-23