After a new agent installation "wrong target" error in receiver.log file

Document ID : KB000040256
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue: 

After a new agent installation, when trying to autoping the agent it fails with errors on autoping not successful.

Looking into the agent logs, we can find message "Wrong target" reported in the "receiver.log" file.

The "Wrong target" means there is a mismatch in the agent definition between the Agent and the Server.

 

Resolution:

The solution is to verify the settings in "agentparm.txt" file under the Agent installation directory.

Then run the following command on the Server node to verify the machine definition :

autorep -q -M machine_name

This command will return the machine definition as in the following example :

insert_machine: machine_name
type: a
factor: 1.00
port: 7520
node_name: machine_name
agent_name: WA_AGENT
encryption_type: DEFAULT
character_code: ASCII

Then compare the settings in the "agentparm.txt" file at the Agent side with the machine definition attributes at the Server side regarding the agent_name, encryption_type and make sure there are all consistent.

A frequent example is customizing the Agent name during the Agent installation procedure while the agent_name by default will be set to WA_Agent in the machine definition.

In such cases the solution will be to double check the Agent_name in file agentparm.txt  and set the same value in agent_name when defining the machine by insert_machine.