AE Transport Case compatibility between different major and minor versions

Document ID : KB000088715
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Automation Engine Transport Case compatibility between different major and minor versions
Resolution:

General

The Transport Case is used to transport (copy) objects between different Automation Engine systems or different clients. In general it’s always upward compatible and never downward compatible:
  • Up to version 8.00A only the major version is important for the compatibility.
  • In version 9.00A also the minor version is important, unfortunately there is no differentiator between service pack and minor version!
  • As of version 10 major and minor versions are important, but not service packs.
 
Source Target Possible?
5.00Aè5.00A
6.00A
8.00A
9.00A
10.0
11.1
11.2
12.0
0EMb0000000HmYz.pngYes
6.00Aè6.00A
8.00A
9.00A
10.0
11.1
11.2
12.0
0EMb0000000HmZ4.pngYes
6.00Aè5.00A0EMb0000000HmZd.pngNo
8.00Aè8.00A
9.00A
10.0
11.1
11.2
12.0
0EMb0000000HmZ9.pngYes
8.00Aè5.00A
6.00A
0EMb0000000HmZi.pngNo
9.00A SP1 … SP5è9.00A SP equal to source SP or higher
10.0
11.1
11.2
12.0
0EMb0000000HmZE.pngYes
9.00A SP6 … SP12 è9.00A SP6 …SP12
10.0
11.1
11.2
12.0
0EMb0000000HmZY.pngYes
9.00A SP1 … SP5è5.00A
6.00A
8.00A
9.00A SP lower than source SP
0EMb0000000HmZn.pngNo
9.00Aè5.00A
6.00A
8.00A
0EMb0000000HmZs.pngNo
10.0è10.0
11.1
11.2
12.0
0EMb0000000HmZT.pngYes
10.0è5.00A
6.00A
8.00A
9.00A
0EMb0000000HmZx.pngNo
11.1è11.1
11.2
12.0
0EMb0000000HmZO.pngYes
11.1è5.00A
6.00A
8.00A
9.00A
10.0
0EMb0000000Hma7.pngNo
11.2è11.2
12.0
0EMb0000000HmZJ.pngYes
11.2è5.00A
6.00A
8.00A
9.00A
10.0
11.1
0EMb0000000HmaC.pngNo
12.0è12.00EMb0000000HmZJ.pngYes
12.0è5.00A
6.00A
8.00A
9.00A
10.0
11.1
11.2
0EMb0000000HmaC.pngNo
 
 
The reasons for compatibility / incompatibility are changes in the database structure / schema. In V9 such changes may happen also when a minor version / service pack upgrade is done.
Note: There is the same behavior for XML – Export and Import!

Error Messages

U0021178 Diese UCDBUP hat Step Nummer &01. Aktuelle Eingabedatei benötigt &02 oder höher.
U0021178 This UCDBUP has step number &01. Current input file requires &02 or higher.
U0021178 Ce UCDBUP a un numéro de step &01. Le fichier actuel requiert &02 ou supérieur.
 
U4005869 Die vorhandene Version der Exportdatei '&01' ist mit der aktuellen Version '&02' nicht kompatibel!
U4005869 The existing version '&01' of the export file is not compatible with the current version '&02'!
U4005869 La version existante '&01' du fichier d'Export n'est pas compatible avec la version actuelle '&01' !