AE System Configuration for running more than 100,000 Agents

Document ID : KB000087527
Last Modified Date : 14/04/2018
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Following are recommendations for AE systems running more than 100,000 agents:

1) tcp_nodelay has to be enabled (this parameter is part of the ucsrv.ini)
tcp_nodelay=

This defines the use of the Naqgle algorithm for the connections of the Automation Engine.

Allowed values: "0" (recommended default value) and "1"

"0" - This activates the Nagle algorithm.
"1" - This procedure is not used.

Set this parameter only in close cooperation with Automic Support.

2) tcp_keep_alive has to be set to 30 (this parameter is part of the ucsrv.ini)
tcp_keepalive_time=
 

The time interval in seconds in which keep-alive packets are sent in order to keep connections.

The default value that depends on the system environment is used when you do not define this setting or when you define the value 0.

Set this parameter only in close cooperation with Automic Support.

3) alivetimeout has to be set to 900 (this parameter is part of the ucsrv.ini)

alivetimeout=

The duration in seconds in which the AE.Nonstop-Server expects a message from the primary work process. If this time span is exceeded, the AE.Nonstop-Server becomes the primary work process.

Default value: 600 seconds

Be careful when you change this parameter. The selected time span should be high enough because the primary work process is busy for quite some time if comprehensive database transactions take place and cannot send keep-alive messages

If you are using Oracle as your database, modify the Oracle client (sqlnet.ora) as follows:
 
TCP.NODELAY=yes   
SQLNET.EXPIRE_TIME has to be set between 1 and 5  - 1 should be the prefered value

Change the following settings in your system wide variable UC_SYSTEM_SETTINGS in client 0, folder DIV_VARIABLES.

AGENT_COUNT_PER_IP to N
AGENT_COUNT_PER_IP

This setting defines whether the IP address of agents should be used for checking the license.

Allowed values: "Y" (default) and "N"
"Y" - The IP address is used for checking the agent's license. The license is not counted if an agent of the same IP address is already logged on.
"N" - The IP address in not checked when the agent logs on. This saves time when numerous agents log on. Note that every agents requires its own license in this case.

AGENT_LOG_CHANGE_PER_MINUTE to 240
AGENT_LOG_CHANGE_PER_MINUTE

The maximum number of log-file changes for agents (per minute).

Allowed values: 20 to n
Default value: 60

CHANGE_LOGGING_DAYS to 1
CHANGE_LOGGING_DAYS

The time period in days after which the log files are changed.

Allowed values: 1 to 32767
Default value: 14

LOG_TO_DATABASE to N
LOG_TO_DATABASE

This saves the server log in the AE database.

Allowed values: Y (default value) and N

Y - The Automation Engine's log messages are saved in the AE database.
N - The Automation Engine's log messages are not saved in the AE database.

MQ_CHECK_TIME to 0
MQ_CHECK_TIME

The interval (seconds) at which message queues are checked (Oracle databases only).

Allowed values: 0 to 1000000
Default value: 600

Value 0 means that no check is made.

SERVER_OPTIONS position 11 to 1
SERVER_OPTIONS
 

Various server settings for performance improvement and trace outputs.

Format: 15-digit string

By default, all options are deactivated.

11th digit

 

Extended output of time-critical database accesses in the log file.

The Automation Engine logs the bind parameters of all time-critical database accesses whose select statements take more seconds than specified in this server option. Any number between 1 and 9 can be specified.

Note that regardless of this setting, bind parameters will not be logged in insert statements.

When this option is used, 3 is often recommended. This way the bind parameter of all selects that take more than 3 seconds will be logged. Therefore, the Automation Engine logs the BIND VARIABLES for long running SQL statements within the LOG file without the need for a trace.

ILM must be used for DB maintenance.  See reference section below.
 

Change the following settings in the agent variable UC_HOSTCHAR_DEFAULT in client 0, folder HOST_VARIABLES

LOG_TO_DATABASE to N
LOG_TO_DATABASE

This stores agent logs to the AE database.

Allowed values: Y (default value) and N

Y - The agent sends its log-file messages also to the Automation Engine which stores it in the Agent object's report.
N - The agent does not send log messages to the Automation Engine. Doing so improves the AE system's performance.

Modify the agent variable UC_EX_HOSTCHAR in client 0, folder EX_VARIABLES.

Remove all the agent entries in this variable and create an entry with key * and value DEFAULT.

To get all of them in place the AE + CP must be restarted (could be done in a round robin).


References
Cause:
Cause type:
Configuration
Root Cause: Running 100,000 Agents or more requires special setup.
Resolution:
This field was added on 30/03/2017. This article has not been updated yet. Refer to the "Description" or "Workaround" sections for solution information.

Fix Status: No Fix

Fix Version(s):
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Workaround :
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