AE - Reporting tool is not using current date time

Document ID : KB000106382
Last Modified Date : 13/08/2018
Show Technical Document Details
Question:
When I run the tool ucybdbrt I get data from processes started 10am previous day to current day 10am.
I want to get the data from the time I run this tool ucybdbrt, how can I do that?
 
My xml as below:
<?xml version="1.0" encoding="UTF-8" standalone="no"?> 
<QUERY version="12.0.3"> 
<file separator=";" type="HTML">PTCR.html</file> 
<client>0400</client> 
<max_rows>50000</max_rows> 
<source>STATISTICS</source> 
<reference> 
<date>TODAY</date> 
<offset>-24</offset> 
</reference> 
<selection> 
<include name="OBJECT_TYPE" value="JOBS"/> 
<include name="OBJECT_NAME" value="PTCR*"/> 
</selection> 
<output order="ascending" sort="START_TIME"> 
<field name="OBJECT_NAME"/> 
<field name="START_TIME"/> 
<field name="END_TIME"/> 
<field name="RUNTIME"/> 
<field name="HOST"/> 
<field name="LOGIN" /> 
<field name="STATUS"/> 
<field name="RETCODE"/> 
<field name="RUN_NUMBER"/> 
<field name="OBJECT_TYPE"/> 
</output> 
</QUERY>



 
Answer:
As you are using the option "Today", the utility uses the current date for creating the report.
<date>TODAY</date>
You can try option "Now", the current date plus the time are used.
<date>NOW</date>
Additional Information:
Note: The specified client's time zone is used for evaluations. If it does not include any time-zone specifications, the system uses the time zone of client 0." 
For more detail, you can check our DB Reporting Tool Document as below:
https://docs.automic.com/documentation/webhelp/english/AWA/12.1/DOCU/12.1/AWA%20Guides/help.htm#AE_AWA_Source/Administration/admin_ReportingTool_GraphicalInterface.htm