AdminUI doesn't show the entire ACO AgentName value

Document ID : KB000075001
Last Modified Date : 10/04/2018
Show Technical Document Details
Issue:
We're running an AdminUI, when we submit 252 multi-value value for the

ACO AgentName, like 252 times this line :

cgt-gcb-tst.mydomains.com_extrawe,application-withmorethanneededtoreachtheendofthelimitofadminuiandpolicy.mymachin.domain.com<index> 

Then the AdminUI report having registered only the 62 first values, leaving the 63rd with value "cgt-" only. When we look in the Policy
Store, we do see the 252 complete values for the same ACO AgentName

as :

cgt-gcb-tst.mydomains.com_extrawe,application-withmorethanneededtoreachtheendofthelimitofadminuiandpolicy.mymachin.domain.com<index> 

where <index> goes 1 to 252.

How can we solve this?
 
Environment:
Policy Server 12.52SP1CR01 on RedHat 5; 
AdminUI 12.52SP1CR01 on RedHat 5; 
Policy Store on eDir 8.8.8; 
 
Cause:
I've searched the given fix for the Policy Server, and there's none
related to the AdminUI and Policy Server, strickly speaking of the
AgentName value.

But there's one which reflects a big change in the way Policy Server
and AdminUI operate and handle data, and there are big chance this
help to solve the current issue.

Defects Fixed in 12.52 SP1 CR06 

https://docops.ca.com/ca-single-sign-on/12-52-sp1/en/release-notes/cumulative-releases/defects-fixed-in-12-52-sp1-cr06 

 00309822/DE143104

In Administrative UI, creating and submitting a realm takes time. 
 
Resolution:
So to fix the issue in your environment, upgrade the Policy Server, 
AdminUI and Policy Store to 12.52SP1CR08 which is the last CR at the 
moment.