Adminui Does Not Start Error: Could not find or load main class Files keyStore.jks

Document ID : KB000118074
Last Modified Date : 24/10/2018
Show Technical Document Details
Issue:
Adminui installed successfully, but it is failing to start reporting below errors: 

2018-10-23 01:56:46 Commons Daemon procrun stderr initialized 
Error: Could not find or load main class Files\CA\siteminder\adminui\standalone\configuration\keyStore.jks 

2018-10-23 02:06:16 Commons Daemon procrun stderr initialized 
Error: Could not find or load main class Files\CA\siteminder\adminui\standalone\configuration\keyStore.jks 

How can we resolve this?
Environment:
Adminui 12.7 on Windows 2012 R2 
Cause:
When the service tries to start, it calls on a 'standalone.conf.bat' file in the 'bin' folder under the AdminUI install location. When it gets to the following line: set "JAVA_OPTS=%JAVA_OPTS% -Djavax.net.ssl.keyStore=%JBOSS_HOME%\standalone\configuration\keyStore.jks", it tries to call on the install location which is 'program files'. Since there is a space in the name of 'program files', it can't find the location of the jks file because it thinks that the location is 'files\standalone\configuration\keystore.jks'. 
 
Resolution:
For the Class Error , Please Uninstall everything related to Adminui from the machine and do a fresh installation. 

Make sure the Registry keys are deleted after uninstall. 

Then Create a directory under C: root drive called CA to be used for the Adminui installation ( C:\CA) 

Run the installation again and select the C:\CA directory as the new install directory path 

The Adminui service should start without any issues.