Administrator Tool won't run - splash screen only

Document ID : KB000117286
Last Modified Date : 30/10/2018
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Issue:
We completely uninstalled, rebooted, and installed again the 64-bit SCM Client (full client) to the E:\Program Files\CA folder. Workbench and the command line utilities seem to start up with no problem, but when trying to start the Administrator Tool, the splash screen comes up and then goes away.
Environment:
CA Harvest SCM v12 and up
Windows 64-bit Full Client installation
Cause:
We uninstalled and reinstalled one more time. Before reinstalling we went to the registry and deleted registry keys: 
o \HKEY_CURRENT_USER\Software\ComputerAssociates\Software Change Manager 
o \HKEY_LOCAL_MACHINE\SOFTWARE\ComputerAssociates\Shared (nothing in the folder) 
o \HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ComputerAssociates\Shared (nothing in the folder) 

After reinstalling we confirmed that this did not resolve the problem. But, we learned: 
- The operating system is Windows 2012 server running in multi-user mode 
- Checked Control Panel -> Programs to confirm that the right versions of the Microsoft VC++ Redistributables were installed 
- Before performing the install, the user's normal practice is to open a command prompt window and execute “change user /install” to put the computer in install mode. 
- After the install, the user's normal practice is to execute “change user /execute” to return to normal operating mode 
- We checked the Windows Event viewer, reviewed the error message we had seen before. We found 2 other messages that might provide some clues: 
o Error – Application Error 
Faulting application name: ADvantage.exe, version: 13.0.3.152, timestamp: 0x5ef692fd 
Faulting module name: KERNELBASE.dll, version 6.2.9200.22141, timestamp: 0x58f11bee 
Exception code: 0xe06d7363 
Fault offset: 0x00017f2a 
Faulting process id: 0x13ed 
Faulting application start time: 0x01d4462192667117 
Faulting application path: E:\Program Files\CA\SCM\ADvantage.exe 
Faulting module path: C:\Windows\SYSTEM32\KERNELBASE.dll 
Report id: d2845da3-b214-11e8-9454-0050569d4750 
Faulting package full name: 
Faulting package-relative application ID: 

o Information – Windows Error Reporting 
Fault bucket 1956682795713282412, type 1 
Event Name: APPCRASH 
Response: Not available 

Problem signature: 
P1: Advantage.exe 
P2: 13.0.3.152 
P3: 5af692fd 
P4: KERNELBASE.dll 
o Warning – UserLoader 
Loading dependency E:\Program Files\CA\SCM\xerces-c_3_1.dll from the current directory was not allowed when attempted by E:\Program Files\CA\SCM\Advantage.exe. Another DLL was found: E:\Program Files\CA\SCM\x86\xerces-c_3_1.dll. For more information, see http://go.microsoft.com/fwlink/?LinkId=718136. 

- We ran the Sysinternals Procmon utility and reproduced the problem. The resulting log file did not provide any clues.
- We ran Dependency Walker on Advantage.exe. The resulting log file did not provide any clues.
Resolution:
One thing to know about the 64-bit SCM Full Client component is that the Workbench portion of the package is 64-bit, but the Administrator Tool is still a 32-bit application. 

One of the errors in the Windows Event Viewer was: 
Loading dependency E:\Program Files\CA\SCM\xerces-c_3_1.dll from the current directory was not allowed when attempted by E:\ProgramFiles\CA\SCM\Advantage.exe. Another DLL was found: E:\Program Files\CA\SCM\x86\xerces-c_3_1.dll. For more information, see http://go.microsoft.com/fwlink/?LinkId=718136

We are theorizing that for some unforeseen reason, the mixture of 64-bit and 32-bit within the SCM Full Client component is causing a problem on this specific machine. For this reason, we suggested:
1. Completely uninstall all SCM components on Kelly’s machine (Enterprise Communicator, CA Harvest SCM Client) 
2. Delete the %CA_SCM_HOME% folder 
3. Reboot the machine 
4. Install the 32-bit version of the full SCM Client component. 

This resolved the problem.