Admin Console on UIM 8.47+ is showing 404

Document ID : KB000005152
Last Modified Date : 14/02/2018
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Issue:

After upgrading to Unified Infrastructure Manager 8.47 or higher we are unable to use the Admin Console. When navigating to the installers the page says that "The UIM Server Home Page has moved"

Environment:
Unified Infrastructure Manager (UIM) 8.47 and higher
Cause:

The new AdminConsole2 uses the wasp probe on the primary hub and by default binds to port :80.

In the wasp.log you may find the following:

Jan 03 14:56:07:435 ERROR [main, org.apache.coyote.http11.Http11Protocol] java.net.BindException: Address already in use: JVM_Bind <null>:80


That means something is binding to port 80 and wasp is unable to create a webserver on that port.

To resolve this, you will need to find what application is binding to port :80 and disable it.


Resolution:

To do so on Windows, open up the command prompt.

Run netstat -ano | findstr :80

If you see 0.0.0.0:80 as a source address, remember the pid.


Run tasklist \v | findstr $pid

Replace $pid with the previous pid.


Shutdown the application, for assistance contact the applications administrator.

Once shutdown, deactivate/reactivate the primary hub wasp. The issue will be resolved.

Additional Information: