Admin Console not Starting Up After Upgrade to 9.0

Document ID : KB000107146
Last Modified Date : 19/07/2018
Show Technical Document Details
Issue:
We are in the process of upgrading from Advanced Auth 8.1 to 9.0. We have upgraded the Strong Auth and Risk Auth components. These components are deployed on the same server. After deploying the adminconsole.war, when starting the Tomcat (8.0.47) service that houses the admin console application we see the following error in the log: 2018-07-19 05:40:37,866 EDT : [localhost-startStop-1] : FATAL : web.init.ArcotAdminInitServlet : [N/A] : [N/A] : [N/A] : [Arcot Admin Console] : [Admin Console] : [N/A] : Application initialization failed, com.arcot.admin.wsclient.riskfort.instancemgmtsvcstub.ArcotRiskFortAdminSvcStub$GetInstances.serialize(Ljavax/xml/namespace/QName;Ljavax/xml/stream/XMLStreamWriter;)V java.lang.AbstractMethodError: com.arcot.admin.wsclient.riskfort.instancemgmtsvcstub.ArcotRiskFortAdminSvcStub$GetInstances.serialize(Ljavax/xml/namespace/QName;Ljavax/xml/stream/XMLStreamWriter;)V at org.apache.axis2.databinding.ADBDataSource.serialize(ADBDataSource.java:90) We receive a 500 error when attempting to access the admin console. We are using Windows Server 2012 R2 and Apache Tomcat 8.0.47.
Resolution:
Follow the below steps to resolve the issue --

1. Stop the Application server ( Tomcat) 
2. Undeploy the arcotadmin.war file and arcotadmin folder. 
3. Go to TOMCAT_HOME/work folder and delete the contents for arcotadmin 
4. Redeploy the arcotadmin war file 
5. Start the Tomcat service and validate.