Addressing CVE-2018-11776 for Identity Management and Governance

Document ID : KB000112291
Last Modified Date : 28/08/2018
Show Technical Document Details
Introduction:
  • From the Red Hat CVE Database entry on CVE-2018-11776:
"Apache Struts versions 2.3 to 2.3.34 and 2.5 to 2.5.16 suffer from possible Remote Code Execution when using results with no namespace and in same time, its upper action(s) have no or wildcard namespace. Same possibility when using url tag which doesn't have value and action set and in same time, its upper action(s) have no or wildcard namespace."
Question:
  • Are any of the CA Identity Management and Governance products vulnerable to CVE-2018-11776, including the Identity Manager, Portal, Governance, Provisioning Manager, and Virtual Appliance?
Answer:
  • The simple answer is "No".
  • Below is a listing of each Identity Management product for reference that have been confirmed as not vulnerable to CVE-2018-11776:
    • Identity Manager
    • Identity Portal
    • Identity Governance
    • Virtual Appliance
    • Provisioning Server