ADA Console failing to receive any data after install

Document ID : KB000020313
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

This environment was two collector servers and a central server.

Issue - After a new installation of ADA 9.3.78 a customer saw the Monitor Service was running, but the console did not receive any data at all.

Root Cause-

The install was not made with the correct documented US/Eng settings. This was the cause in this instance.

Please see tech doc - TEC573085 for full details and resolution if this likely to be reason you have this problem. Please do check install regionalsettings and do not assume they are correct.

Snip;

Having incorrect Regional settings on the server can cause various errors in the web interface and in the product logs (any NetQoS product) with errors
referencing invalid Int32 strings, invalid input string, and/or invalid DateTime entries.

This issue is caused when Windows servers is/are using non-US regional settings, or using date formats set to: dd MMMM yyyy.

An example of this is having regional settings set to "English (United Kingdom)".

All NetQoS products require that the Regional Settings on the server be set to US Regional settings with the proper sShortDate and sLongDate settings in the registry.

Solution:

You can run the USsettings.exe included in the NQ Support Tools and reboot the server to apply the below changes, or you can perform the steps manually as described below.

Enter the Windows regional settings menu through Control Panel on the server itself.

  1. Modify this setting to "English (United States)".

  2. Click OK.

  3. Now, enter the Windows Registry, and highlight My Computer.

  4. Go to Edit > Find, and search for string 'yyyy'.

  5. Change only keys sLongDate and sShortDate to the following values:

    sLongDate = dddd, MMMM dd, yyyy
    sShortDate = M/d/yyyy

Use the F3 key to continue searching the registry for more instances of these keys.

Keep doing so until it states it has finished searching the registry.
The regional settings change in the control panel doesn't always update every registry entry and that can still affect the database if all entries are not updated manually in the registry. This is a windows issue, so the full search through the registry is necessary.

After all changes are made, Restart the Server to apply the registry changes.

Should you need it, USsettings.exe, should be here;

ftp://ftp.ca.com/pub/netqos/supporttools/releasedtools/