ACTIVATE_UC_OBJECT behavior with 'Generate at Runtime'

Document ID : KB000088121
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
N/A

When utilizing ACTIVATE_UC_OBJECT to call a subtask the ACTIVATE_UC_OBJECT waits until the end of the 'Generation' phase and not the 'Activation' phase depending on 'Generate at Runtime':

Without Generate at Runtime:
3/27/2016 5:10:30 PM - U00012109 Script '.SCRI.ACTIVATE_CHILD_TASK' (RunID '0001064600') ended normally.
3/27/2016 5:10:30 PM - U00020000 Message from 'AUTOMIC/AUTOMIC': 'End: 171030'
3/27/2016 5:10:30 PM - U00012109 Script 'SCRI.WAIT_60' (RunID '0001064601') ended normally.
3/27/2016 5:09:30 PM - U00020000 Message from 'AUTOMIC/AUTOMIC': 'Start: 170930'

With Generate at Runtime:
3/27/2016 5:13:02 PM - U00012109 Script 'SCRI.WAIT_60' (RunID '0001064603') ended normally.
3/27/2016 5:12:02 PM - U00012109 Script 'SCRI.ACTIVATE_CHILD_TASK' (RunID '0001064602') ended normally.
3/27/2016 5:12:02 PM - U00020000 Message from 'AUTOMIC/AUTOMIC': 'End: 171202'
3/27/2016 5:12:02 PM - U00020000 Message from 'AUTOMIC/AUTOMIC': 'Start: 171202'

Cause:
Cause type:
By design
Root Cause: Refer to description
Resolution:
This field was added on 30/03/2017. This article has not been updated yet. Refer to the "Description" or "Workaround" sections for solution information.

Fix Status: Released

Fix Version(s):
Documentation 11.2.2 - Already available
Additional Information:
Workaround :
Do not utilize 'Generate at Runtime'