Action Item should be sent irrespective of Assignees rights on the object

Document ID : KB000031138
Last Modified Date : 14/02/2018
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Problem:

Workflow processes are failing with error message:

BPM-0519: Internal Process Engine Error. Contact your site administrator (Object with name 'this....' refers to object '.....' bound to the instance '500xxxx' is not found)

Even though process is expected to fail, the error message should able convey the actual reason that the assigned user does not have required security access rights. 

Steps to Reproduce:  

  1. Create a new process
  2. In the Objects tab
    • Select Change Request as the Primary Object
    • Select Parent as Linked Object and give a name "prj"
  3. Go to Steps > Create a new step
    • Create a Manual Action
    • In Description field click on goggles icon to add Attribute Variables
    • In the filter, select Object Name:"thisChangeRequest" and click on Filter, then Select Name 
    • In subject and description, put the following test: "Added to: ${thisChange Request.name}"
    • In Assignees, click on browse > in the filter click on Show All> Select Manager (Object: prj)
  4. Link the steps and validate and activate all 
  5. Create a new resource (Administration > Resources) and do not give any access rights 
  6. Create a new project and select the new user created as the Project Manager 
  7. Go to Risks/Issues/Changes, Change Request page 
  8. Create a new Change Request - Just fill out the required fields 
  9. Go to Processes tab of the new change request 
  10. Initiate the new process

Expected Result:  Process succeeds and the action item produced does not have a link to the change request.     

Actual Result:   Process failure message : 'BPM-0519: Internal Process Engine Error. Contact your site administrator (Object with name 'this....' refers to object '.....' bound to the instance '500xxxx' is not found)

Environment:

Applies to all supported PAS environments for specified releases.

Cause:

Caused by CLRT-77541   

Resolution:

Resolved in CA PPM 14.2 Generic Patch #4.

Resolved in CA PPM 14.3  

Workaround:

For this specific scenario, if you want the assignee to access the change request, check the access rights to ensure they have access rights:

  • Project – Navigate for the Project Manager
  • Project - Risk, Issue, Change Request - Create/Edit : For that particular project
  • Project - Risk, Issue, Change Request – Delete : For that particular project 
  • Project - Risk, Issue, Change Request – View : For that particular project 

Additional Information:

Reference TEC1398937  : PPM 14.2 Generic Patch available to resolve reported issues

Reference CA PPM Resolved Defects Index for CA PPM 14.3