Action item - Link to object does not work after object label is changed

Document ID : KB000103232
Last Modified Date : 25/06/2018
Show Technical Document Details
Issue:
Action item - Link to object does not work after the Object label is changed.
When clicking the link to the Object on the Action Item instance, the link is redirecting to the new Instance creation page instead of the existing Instance of the Object.

Steps to reproduce:

Working as expected
  • Create a new object.
  • Give all global rights of object (create/edit) to the Admin user.
  • Create a simple process based on the new created Object that sends an AI to the Admin user.
  • Create an instance of the object.
  • Run the process. 
  • Go the the action item and click on the Object link.
  • Expected result: you are redirected to the object instance page.
  • Result: you are redirected to the object instance page.

Now Change the label of the object and push the changes in Studio
  • From Administration / Objects, change the name of the Object. 
The problem appears
  • Create a new instance of the object. 
  • Run the process
  • Go the the Action Item and click on the instance of the object link.
  • Expected result: you are redirected to the object instance page
  • Result: you are not redirected to the object instance page. Instead you are redirected to the instance creation page for the object.
Environment:
CA PPM version 15.2
Resolution:
The problem is not reproducible on versions 15.3, 15.4 and 15.4 SP1.
To resolve this issue, if faced of versions 15.2 or previous versions, upgrade to a later version of CA PPM.