Accessing AdminUI URL returns HTTP 404

Document ID : KB000008341
Last Modified Date : 14/02/2018
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Issue:

Accessing WAM UI(/iam/siteminder/console) returns HTTP 404.

Cause:

The reason for this is because the "SiteMinder" applications which are serviced at /iam/siteminder/* are not deployed.

You need to have either respective *.dodeploy file matching the .ear file to ensure the application would be deployed or you need *.deployed to inform the jboss this application is already deployed and should be made accessible.

 

Message in server.log:

(DeploymentScanner-threads - 1)JBAS015003: Found castylesr5.1.1.ear in deployment directory. To trigger deployment create a file called castylesr5.1.1.ear.dodeploy

(DeploymentScanner-threads - 1)JBAS015003: Found iam_siteminder.ear in deployment directory. To trigger deployment create a file called iam_siteminder.ear.dodeploy

 

Message in boot.log
(Controller Boot Thread) JBAS015954: Admin console is not enabled

Resolution:

Missing <adminui>\standalone\deployments\castylesr5.1.1.ear.dodeploy & <adminui>\standalone\deployments\iam_siteminder.ear.dodeploy files could cause this behaviour.

 

There are two ways you can fix this problem. 

 

1. Create empty files called castylesr5.1.1.ear.dodeploy & iam_siteminder.ear.dodeploy files under \\adminui\standalone\deployments\ directory. 

And start 'SiteMinder Administrative UI' service.

This *.dodeploy would deploy the service and you would be able to access the /iam/siteminder/* resources.

 

2. Copy castylesr5.1.1.ear.deployed & iam_siteminder.ear.deployed files from backup. Or create files with following contents.

The contents of files could have as below; 

Filename: castylesr5.1.1.ear.deployed
Content(specify the .ear filename that need to deploy in single line): castylesr5.1.1.ear 

Filename: iam_siteminder.ear.deployed
Content(specify the .ear filename that need to deploy in single line): iam_siteminder.ear