ACC - "Change Package" window empty. ACC cannot find a compatible package

Document ID : KB000006407
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

ACC - "Change Package" window empty. ACC cannot find a compatible package

Workflow:

1.Create a new WAS Liberty package

2.Go to the appsever and deploy the agent package manually.

3.Go back to ACC UI, open the Agent package and change the value for some hot properties.

1.png

4.Select the Agent, view the compatible package, you can push this new configuration to the agent

2.png

4.Edit the Agent package and remove "Garbage Collection"

3.png

5.Select the Agent again, click Switch button, the "Change package" window is now empty

4.png

 

Cause:

This window allows a user to switch between the versions of packages running on an application server.
However, you should only be able to get into this dialog if there are any packages which can be applied (compatible packages) instead of the existing one.

In the above use case, "Garbage Collection" is a cold bundle so removing it caused the incompatibility of packages so "Change Package" window was empty.

From ACC help menu:

“The new package version must be compatible with the package the agent is currently using. This means that the environment settings must match (osName, processName, agentVersion properties), both packages must contain the same 'cold' bundles and have identical property overrides, and only changes to hot deployable (dynamic) bundles are allowed. Dynamic bundles are marked with Dynamic icon icon in bundle lists.”

Resolution:

Make sure agent packages are compatible.


Additional Information:

To further troubleshoot issue this type of issues, check the result of the package REST responses of the version of the packages, it will help determine if the packages should be able to be deployed using this mechanism or not.

Once logged into the ACC UI, open a new tab and enter the below URLs:

https://server:8443/apm/acc/package/X
https://server:8443/apm/acc/package/X/compatiblePackages
https://server:8443/apm/acc/package/Y

Where X and Y are the ids of the currently running and the desired package.
Open a support case and attach these responses for analysis.