Impossible to import the security via Upgrade - Import Security on the Univiewer Console.

Document ID : KB000086916
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
    At the end of this import procedure a popup error message on UVC will appear with the message:

########################################################################################
com.orsyp.UniverseException: org.springframework.dao.DataIntegrityViolationException
########################################################################################

On the univiewer.log this error message appear:

#########################################################################################
|2013-08-20 11:44:20,575|ERROR|http://vmstlsup20:8080/univiewer_webconsole_4.0.15_all_os|AWT-EventQueue-0|com.orsyp.kmeleon.environment.ExceptionManager|An error occured on ENVIRONMENT: (node = null environment = null)
java.lang.reflect.UndeclaredThrowableException
at com.sun.proxy.$Proxy4.create(Unknown Source)
at com.orsyp.kmeleon.document.security.du5import.userlist.model.SysUserEntityItem.save(SysUserEntityItem.java:81)
at com.orsyp.kmeleon.document.security.du5import.userlist.model.SysUserEntityItem.save(SysUserEntityItem.java:16)
at com.orsyp.kmeleon.document.security.du5import.common.view.DU5SecurityImportWizard$1.runInternal(DU5SecurityImportWizard.java:182)
at com.orsyp.kmeleon.util.process.NotifyProcess.run(NotifyProcess.java:44)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: com.orsyp.UniverseException: org.springframework.dao.DataIntegrityViolationException
#########################################################################################

Patch level detected:Univiewer Console 4.0.00
Product Version: Dollar.Universe 6.0.0

Description :Impossible to import the security via Upgrade - Import Security on the Univiewer Console.
 
Environment:
OS: Windows
OS Version: all Windows
 
Cause:
Cause type:
Defect
Root Cause: N/A
 
Resolution:
The issue has been resolved since Univiewer Console 6.1.01

Fix Status: Released

Fix Version(s):
Component: Univiewer.Console
Version: Dollar.Universe 6.1.01
 
Additional Information:
Workaround :
N/A