Engines not starting with the startup command.

Document ID : KB000086766
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Affects Release version(s): 5

Error Message :
Universe.log will have the following entry
#########################
<< 2012-12-12 16:38:46 0010300/uxstratm /u_io_callsrv_gen /000000000 - Making connection to IO server: user (W32,NODE,DOMAIN,USER) is not allowed on NODE,COMPANY,X
#########################

Patch level detected:Dollar Universe 5.6.0
Product Version: Dollar.Universe 5.6.0 FX25010

Description :Some Dollar Universe engines are not started when executing uxstartup command from command line.
 
Environment:
OS: All
OS Version: All OS
 
Cause:
Cause type:
Configuration
Root Cause: Proxy rule defined prevents user from having full access to the node.
 
Resolution:
For example, dollarUadmin is the login user and the proxy rule contains the following

W32 * * * *SAME

There must be a dollarUadmin user in order for dollarUadmin to have access to Dollar Universe.

Various solutions are possible:

1. Add a proxy rule that maps the dollarUadmin user to an existing Dollar Universe user (eg. univa)

For example,
%UXMGR%\uxsetenv
%UXEXE%\setproxy W32 * * dollarUadmin univa
%UXEXE%\loadproxy_io
where Area can be A, I, S and X

For this issue, the production area suffice.
You may also restart Dollar Universe to reload the proxy.

2. Create a Dollar Universe user called dollarUadmin

Fix Status: No Fix
 
 
Additional Information:
Workaround :
N/A