The kit/Fix for Dollar Universe 5.x cannot be installed on a Linux server with kernel 3.x

Document ID : KB000085844
Last Modified Date : 30/04/2018
Show Technical Document Details
Issue:
Affects Release version(s): 5

Error Message :
During patch installation:

#######################################

---------------------------------------------- 
Application of the update kit xxxxx 
---------------------------------------------- 

Verify the operating system compatibility... 

This kit cannot be installed on this host. It can be installed 
only on a host with the following characteristics: 
- OS Name: Linux 
- Version: 2.4.21-4 or greater 
- CPU Type: i686 

Installation aborted. 
#######################################


During kit installation:

#######################################
This kit cannot be installed on this host. It can be installed 
only on a host with the following characteristics: 
- OS Name: Linux 
- Version: 2.4.21-4 or greater 
- CPU Type: i686 

# => Cancelling the upgrade procedure !
#######################################

Patch level detected:Dollar Universe 5.6
Product Version: Dollar.Universe 5.6.0 FX25010

Description :The kit/Fix for Dollar Universe 5.x cannot be installed on a Linux server with kernel 3.x
Environment:
OS: Linux
OS Version: kernel 3x
Cause:
Cause type:
Defect
Root Cause: This is a defect in the installation procedure.
Resolution:
1/ For Patch installations:
Final solution for patches is available since FX25002 in Dollar Universe v533 and FX24991in Dollar Universe v56.

2/ For Kit installation:
The installation kits will not be recreated so the instructions to workaround the problem during kit installation on such OS:

In file DUSxxx/tools/u_check_system.ksh
at line 365, just after. # 2.4.21-4
add the following line:
#####################
[${target_maj_release} -gt ${kit_maj_release} ] && return
#####################

3/ For previous Dollar Universe patches, you can comment these lines in "uxinstall_main.ksh" file

# Checking system prerequisites (by comparing the 2 files describing OS) :
#$UXKIT_OUTIL/u_check_system.ksh $UXKIT_OUTIL/os_release.dat /tmp/os_of_installation.dat
#if [ $? -ne 0 ]
#then
# echo "# => Cancelling the upgrade procedure !"
# echo "#"
# rm -f /tmp/os_of_installation.dat > /dev/null 2>&1
# exit 1
#fi

Fix Status: Released

Fix Version(s):
Component: Application.Server
Version: Dollar.Universe 5.6.0 FX25010
FX25010
Additional Information:
Workaround :
N/A