Too many components discovered, possibly resulting in slow system.

Document ID : KB000045131
Last Modified Date : 14/02/2018
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Issue:

After discovering a large number of new components CAPC dashboards are rendering slowly,  How can we identify which components are at fault?

 

Environment:

2.x

 

Cause:

An example would be applying the QOS monitoring profile, which can add many elements to your database and cause the polled item count to increase exponentially

 

Resolution:

Using QoSClassMap as the example, here is how you can identify how many components have been added to your database

 

 Here is how you verify counts:

  1. select facet_qname, count(*) from dauser.v_item_facet group by 1 order by 2 desc; 

facet_qname | count 

---------------------------------------------------------------------------------------+--------- 

{http://im.ca.com/inventory}Pollable | 8015189 

{http://im.ca.com/inventory}DeviceComponent | 7998605 

{http://im.ca.com/inventory}DiscoveryInfo | 7996722 

{http://im.ca.com/core}Syncable | 7871435 

{http://im.ca.com/inventory}Hierarchy | 4791490 

{http://im.ca.com/inventory}QoSClassMap | 4783021 

{http://im.ca.com/inventory}Port | 2036705 

 

In this instance almost 5 million QoSClassMap elements have been added to the database

 

Additional Information:

In this example the excessive number of QoSClassMap elements caused CAPC dashboards to render very slowly, and caused overall slowness throughout the environment.  Please contact support for assistance cleaning up the elements in question