6.4.2 install fails not able to connect to postgres db

Document ID : KB000097829
Last Modified Date : 23/05/2018
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Issue:
While upgrading jaspersoft from version 6.3 to 6.4.2, we are seeing an error in the Setup GUI -unable to connect to postgres database

Error - Unable to connect to postgres database
Environment:
Spectrum 10.2.3
CABI Jaspersoft 6.4.2
Linux RHEL 7
Cause:
The postgres database needs to be running for the installer to connect. In many cases Services are shut down prior to running an upgrade, which would mean posgres would also be shut down prior to the upgrade. However, when starting services to also start postgres, services which do need to be shut down such as Tomcat will now be started as well. To get around this, you can start postgres by itself while leaving the other CABI services shut down for the upgrade. 
Resolution:

- assuming the <CABI ROOT> is default /opt/CA/SharedComponents/CA Business Intelligence

1. nav to <CABI ROOT>/postgres/bin
 
2. log in as postgres user: 

su postgres 

3. start postgres: 

./postgres -D /opt/CA/SharedComponents/CA\ Business\ Intelligence/postgresql/data 

- there should be output on the screen showing that posgres db is started :

postgres database started

4. Run the 6.4.2 Installer again