403 error when trying to open a cabi dashboard in ump

Document ID : KB000124176
Last Modified Date : 07/01/2019
Show Technical Document Details
Issue:
In UMP with Shared CABI (cabi_external), the UMP CABI dashboards fail to load and throw a 403 - Forbidden error.


403 error when trying to load a CABI dashboard in UMP
Environment:
UIM 8.51
cabi_external 3.20
Shared CABI (Jaspersoft) 6.3
Cause:
The keystore files used for authentication under the covers between UIM - UMP to authenticate the user with CABI may have been corrupted or are out of date.
/opt/CA/SharedComponents/CA Business Intelligence/apache-tomcat/webapps/jasperserver-pro/WEB-INF/config/uim.properties
/opt/CA/SharedComponents/CA Business Intelligence/apache-tomcat/webapps/jasperserver-pro/WEB-INF/config/uim.jks

 
Resolution:
1- Validate the login to Jaspersoft / CABI
    http://cabiJaspersoftHostname:8080/jasperserver-pro/
    Login: superuser
    Password: newPassword
2- Navigate to the "cabi_external" robot and Edit the "cabi_external" probe in Infrastructure Manager or Admin console.
    Add a new key under "setup" called "cabi_rest_password_cleartext"
Raw Configure CABI_EXTERNAL
3- Copy the "/opt/nimsoft/probes/service/cabi_external/config/bin/uim-cabi-overlay-installer.jar" file from the "cabi_external" robot to the "/opt/CA/SharedComponents/CA Business Intelligence" folder on the Shared CABI/Jaspersoft server.
4- Run the command: "./jre/bin/java -jar uim-cabi-overlay-installer.jar"
    If successful, this should show the following output:
      INFO  com.ca.cabi4uim.UimCabiOverlayInstaller : Successfully installed UIM Cabi Overlay changes. Please restart the CABI application server to realize changes.
5- /opt/CA/SharedComponents/CA Business Intelligence/stopServers.sh
6- /opt/CA/SharedComponents/CA Business Intelligence/startServers.sh
7- Deploy ump_cabi package to the UMP robot.
8- Wait a few minutes and test the Unified Dashboards in the UMP