14.1 Unknown Warning in Service Catalog log

Document ID : KB000072855
Last Modified Date : 12/03/2018
Show Technical Document Details
Issue:
We encountered an unknown error inside Service Catalog.
It looks like an connection is trying to be established to a server "TEST" (this is a test catalog server).
I do not believe that a test server is defined anywhere inside production server.
The warning is repeated every 5 seconds. Entire view.log is in attachment. 
Log Warning:
2018/03/04 14.29.50.418 WARN  [triggerStartAsyncNetworkBridgeCreation: remoteBroker=tcp://InazagrSCTest/10.145.50.241:7777@60924, localBroker= vm://brkr-68799372C40F4F419B28F41778363501#8954] [TransportConnection] Failed to add Connection brkr-68799372C40F4F419B28F41778363501->brkr-67D8E53D24444903A78B8BBB77B9F5B5-51307-1520004286320-4479:1
javax.jms.InvalidClientIDException: Broker: brkr-68799372C40F4F419B28F41778363501 - Client: nc-68799372C40F4F419B28F41778363501_brkr-67D8E53D24444903A78B8BBB77B9F5B5_inbound_brkr-68799372C40F4F419B28F41778363501 already connected from vm://brkr-68799372C40F4F419B28F41778363501#4
at org.apache.activemq.broker.region.RegionBroker.addConnection(RegionBroker.java:246)
Environment:
Windows, running CA Service Catalog.
Cause:
Catalog is multicasting to a local addres in same domain on port 7777 by default. 
Without setup of any clustering. As found under: 
https://docops.ca.com/ca-service-management/17-0/en/implementing/implement-ca-service-management-17-0/how-to-deploy-ca-service-management-17-0/how-to-implement-ca-service-catalog-17-0/post-installation-tasks-ca-service-catalog/optional-implement-ca-service-catalog-clustering/prerequisites-for-clustering
 
Resolution:
Thinking with the client on this direction about 2 servers in the same domain, using port 7777.
As the solution for this case: Reset the test environment to e.g. port 7778. Different from 7777 I mean. 
And then restart the test server(when allowed) to see a difference in behaviour. 

In C:\Program Files\CA\Service Catalog\config.properties under "jms.*" 
Check and change the settings in there as for the port-number.
############################################################### 
# JMS related configuration 
############################################################### 
#multicast://default = multicast://239.255.2.3:6155 
#static:(tcp://<host1>:<port>,tcp://<host2>:<port>,...) 
jms.networkConnectorUri = multicast://default 
jms.discoveryUri = multicast://default 
jms.port = 7777